Skip to main content

BINGO Manager

Start BINGO programs and tools

Create a desktop shortcut to the BINGO Manager executable, bbman.exe, in the ..\Bingo\bin\ directory.

Double-click the BINGO Manager icon to start the program. In File Explorer, select the directory containing your BINGO files (for example, \BINGO\Demo\Simple_AT), then drag it to the directory field in the BINGO Manager window. Alternatively, select a project directory using File > Select Project. The selected directory becomes the current working directory for BINGO Manager and for all programs started from it.

Changing the working directory also affects programs that are already running if Tools > Auto CD is selected. You can manually change the directory of running tools using Tools > CD Tools.

To run BINGO and SKIP in a cycle that automatically eliminates and reactivates errors until block processing is complete, select Run > Cycle or click Cy. Select Run > Parameters to open the parameter window and configure the cycle options.

Use Run > Parameters to configure RELAX, BINGO, SKIP, and Cycle. Each tab provides context-sensitive menus when you right-click it.

The parameter window is an independent process. Save the selected parameters manually to the project file, whose default name is project.dat, using File > Save, Ctrl+S, or Ctrl+X. Right-click menus are also available for saving, importing, and restoring defaults.

BINGO project filename

All filenames for BINGO processing can be set in the parameter window except the project filename itself. Set this filename using File > Project File in BINGO Manager.

Important

To use the default filename project.dat, leave the filename field empty.

Click GeoInEditor to create or edit the geoin.dat file in a separate process.

BINGO Manager provides buttons for several functions, including editing geoin.dat and viewing bingo.lis. Select an editor using File > Select Editor. If no editor has been selected, the program prompts you to choose one when it is first needed.

BINGO batch processing

To run BINGO programs unattended, for example overnight, create a batch process that runs several programs in several project directories.

This file may be located anywhere in the computer. The following commands are available:

CommandDescription
CD directory_nameChange the working directory. This must be the first command in the batch file.
COPY file_name file_nameCopy a file.
REN file_name file_nameRename a file.
ImgCleanBt [parameters]Start the batch version of ImgClean.
MakeGrid [parameters]Start MakeGrid, which is part of BgExport.
SamBatch [parameters]Start the batch version of SAMBA.
TieCheck [parameters]Start TieCheck.
Relax [project_file_name]Start RELAX.
BingoMP [project_file_name]Start BINGO.
Skip [project_file_name]Start SKIP.
CycleRun BINGO and SKIP in a cycle.
Report [report_file_name]Create a BINGO PDF report.

Empty lines are allowed, and the input is not case-sensitive. Lines starting with # or * in column 1 are ignored.